Speck device not fo...
 
Notifications
Clear all

Speck device not found

13 Posts
5 Users
2 Likes
1,371 Views
1
Topic starter

I have an issue when I try to connect to the Speck2f devkit. I used the chip without problems since some days ago but then I started to have issues. This is what I observed:

  • Initially, I was getting either the "device not found" error or ,after the device was found, the process would stall without getting anywhere. I  plugged/unplugged the device and upgrade sinabs-dynapcnn and the problem seemed to be solve. 
  • Now, I always get the "device not found" error. Moreover, the device sometimes appears between the usb devices detected and sometimes not (Cypress Semiconductor Corp. Speck2fDevKit)
    The chip started correctly once or twice but I couldn't identify any reason for that.

Thank you very much for your help!

DylanMuir DylanMuir 08/09/2023 7:02 pm

Hi @caterina-caccavella , it sounds very much like a USB compatibility issue. Please try on a different USB port, which you know for sure supports USB 3.1, and with a USB3.1 compatible cable (ideally the one shipped with Speck). If you are connecting via a USB hub, please try connecting directly without the hub.

Lyes Khacef Lyes Khacef 11/09/2023 2:09 am

The USB cable shipped with Speck was working fine until a few days ago, we don't know what caused the issue.

2 Answers
1

Hi @caterina-caccavella ,there might be a USB interface problem, you can try the following methods:
1. Change to another usb interface, it is very likely that the usb interface used now is unstable,;
2. Confirm the interface is USB3.0, not USB2.0;
3. It is better to use the cable that comes with the computer;
4. If you use the virtual machine to connect the devkit, please make sure the USB interface is compatible.

Lyes Khacef Lyes Khacef 20/09/2023 11:02 pm

Hi @xiaolin-hou, thanks again for your answer, however the issue is present with different cables and different computers. When I check the name of the device via "ususb", then:
- When I get "ID 337d:5bca SynSense Speck2fDevKit", the devkit works fine.
- When I get "ID 04b4:00f1 Cypress Semiconductor Corp. Speck2fDevKit", the chip is not found.

What is weird is that the name of the DynapCNN devkit is "ID 04b4:5bc1 Cypress Semiconductor Corp. DynapcnnDevKit", but it is found correctly. Perhaps it is a boot issue caused by a mismatch of firmware/software?

Please tell us how we should proceed. Thanks again for your time and help.

Avatar XiaoLin Hou 21/09/2023 11:39 am

Hi @Lyes, Thanks. You can find a list of SynSense's device name(used to open a device), vendor is and product id for all supported devices in the documentation: https://synsense-sys-int.gitlab.io/samna/install.html. So when DynapcnnDevKit correspond 04b4, 5bc1, it works fine; when Speck2fDevKit correspond 337d, 5bca , it also works fine; when Speck2fDevKit correspond "ID 04b4:00f1 Cypress Semiconductor Corp. Speck2fDevKit", the USB interface is identified USB 2.0 not USB 3.0, so the chip is not found.

Lyes Khacef Lyes Khacef 21/09/2023 7:22 pm

Hi @xiaolin-hou, thanks for the explanation!

I tried the devkit with different computers and USB cables, and I still get the same issue. I think it usually happens when the chip "stalls" (perhaps too many events from the DVS), then it goes from USB3.0 to USB2.0 while I did not change the USB port.

Could it be a firmware issue? Any idea how I can address this issue?

0
Topic starter

Hi @xiaolin-hou

thank you very much for your quick answer!

I tried different USB 3.0 cables. I noticed that the name of the device detected (lsusb command) change with different cables (or even with the same cable) between Cypress Semiconductor Corp. Speck2fDevKit and SynSense Speck2fDevKit.

When the device is seen as SynSense Speck2fDevKit, it works correctly. Even though now I can use it I noticed that with another cable the name of the device would switch from Cypress Semiconductor Corp. Speck2fDevKit to SynSense Speck2fDevKit after the device is detected, causing the stall of the process. Do you know what could be the issue?

Thank you very much for your help again!

 

 

Avatar Yudi 22/09/2023 11:13 am

Hi @caterina-caccavella , sorry you are experiencing this problem. It looks like you have a cable that can work well with the dev kit? If so, I think the other cable may has some problems and cause the usb changes from usb3.0 to usb2.0

Share:
Close
Back To